summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-02-25 13:00:08 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-03-10 18:11:35 +0000
commitb374a59e0e2ef52fed737f6db9ee1e40caca46ea (patch)
tree2c7a0c57562f9c749b483677185548c567807657 /tests/Makefile.am
parentf5b7a1d2da68bc6daf65cfe456f335105cc9e584 (diff)
tests: automake: keep the libs link at the final stage
Currently the static archive libdrmtest.la links against libdrm.la. Only to have both added to the executables' LDADD. Simplify things a bit, by doing the link in the final module (the executables/tests in this case). Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a1106fce..d5269f94 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -39,11 +39,10 @@ libdrmtest_la_SOURCES = \
drmtest.c \
drmtest.h
-libdrmtest_la_LIBADD = \
- $(top_builddir)/libdrm.la \
+LDADD += \
+ libdrmtest.la \
$(LIBUDEV_LIBS)
-LDADD += libdrmtest.la
XFAIL_TESTS = \
auth \