summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-03-10 18:02:20 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-03-10 18:11:35 +0000
commitf5b7a1d2da68bc6daf65cfe456f335105cc9e584 (patch)
tree31447d961a98b7413f338110c9f9b820e15ac813 /tests/Makefile.am
parent58e5010a097e48705d1f1cf4e09ba45954725524 (diff)
tests: move the SUBDIR at the top of the makefile
None of the subdirs require the modules built in the local makefile, so moving them at the top makes things a hell lot easier to read. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am28
1 files changed, 15 insertions, 13 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a2d82659..a1106fce 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,14 +1,3 @@
-AM_CFLAGS = \
- $(WARN_CFLAGS)\
- -I $(top_srcdir)/include/drm \
- -I $(top_srcdir)
-
-LDADD = $(top_builddir)/libdrm.la
-
-check_PROGRAMS = \
- dristat \
- drmstat
-
SUBDIRS = modeprint proptest
if HAVE_LIBKMS
@@ -28,6 +17,21 @@ SUBDIRS += tegra
endif
if HAVE_LIBUDEV
+SUBDIRS += vbltest
+endif
+
+AM_CFLAGS = \
+ $(WARN_CFLAGS)\
+ -I $(top_srcdir)/include/drm \
+ -I $(top_srcdir)
+
+LDADD = $(top_builddir)/libdrm.la
+
+check_PROGRAMS = \
+ dristat \
+ drmstat
+
+if HAVE_LIBUDEV
check_LTLIBRARIES = libdrmtest.la
@@ -54,8 +58,6 @@ TESTS = \
updatedraw \
name_from_fd
-SUBDIRS += vbltest
-
check_PROGRAMS += $(TESTS)
endif