summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-03-17 00:19:27 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-03-17 22:37:05 +0000
commitd20413a7ce5816abe1127ffffc5bcab82f268c16 (patch)
tree022a9f59efb9288c3dad61ea3d2fec20b15e59f9 /configure.ac
parent648508518ef4f199eee58dbca8d6412af989fe71 (diff)
configure.ac: error out if building freedreno_kgsl without freedreno
The former is a subset of the latter. Error out early so the user is aware that they are doing something very wrong. Cc: Rob Clark <robdclark@gmail.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Rob Clark <robdclark@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7f76083e..6e45fa85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -321,6 +321,11 @@ if test "x$FREEDRENO" = xyes; then
AC_DEFINE(HAVE_FREEDRENO, 1, [Have freedreno support])
fi
+if test "x$FREEDRENO_KGSL" = xyes; then
+ if test "x$FREEDRENO" != xyes; then
+ AC_MSG_ERROR([Cannot enable freedreno KGSL interface if freedreno is disabled])
+ fi
+fi
AM_CONDITIONAL(HAVE_FREEDRENO_KGSL, [test "x$FREEDRENO_KGSL" = xyes])
if test "x$FREEDRENO_KGSL" = xyes; then
AC_DEFINE(HAVE_FREEDRENO_KGSL, 1, [Have freedreno support for KGSL kernel interface])