summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2025-04-04 03:12:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2025-04-04 03:32:30 +0300
commitce2c37356c674e5893f80786616355b4659b43ad (patch)
tree8da7297a20bcee66f73eaddcd42a84483a0b30d1 /src/meson.build
parenta4c13e7ce77b86cf36bc6b0a79220b97f8b2a1b8 (diff)
Convert from make to meson
Meson makes cross compilation easier. Replace the make-based build system with meson. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
new file mode 100644
index 0000000..3a6118b
--- /dev/null
+++ b/src/meson.build
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: CC0-1.0
+
+gen_image_sources = files([
+ 'gen-image.c',
+])
+
+monotonic_ts_sources = files([
+ 'monotonic-ts.c',
+])
+
+m_dep = cc.find_library('m', required : false)
+
+executable('gen-image', gen_image_sources,
+ dependencies : [m_dep],
+ install : true,
+ install_dir : '')
+
+executable('monotonic-ts', monotonic_ts_sources,
+ dependencies : [m_dep],
+ install : true,
+ install_dir : '')