summaryrefslogtreecommitdiff
path: root/py/pykms/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'py/pykms/meson.build')
-rw-r--r--py/pykms/meson.build12
1 files changed, 5 insertions, 7 deletions
diff --git a/py/pykms/meson.build b/py/pykms/meson.build
index b29cd9f..e030ce8 100644
--- a/py/pykms/meson.build
+++ b/py/pykms/meson.build
@@ -4,13 +4,11 @@ if py3_dep.found() == false
subdir_done()
endif
-if get_option('system-pybind11').enabled()
- pybind11_dep = dependency('pybind11')
-elif get_option('system-pybind11').disabled()
- pybind11_proj = subproject('pybind11')
- pybind11_dep = pybind11_proj.get_variable('pybind11_dep')
-else
- pybind11_dep = dependency('pybind11', fallback : ['pybind11', 'pybind11_dep'])
+pybind11_dep = dependency('pybind11', fallback : ['pybind11', 'pybind11_dep'],
+ required : get_option('pykms'))
+
+if pybind11_dep.found() == false
+ subdir_done()
endif
pykms_sources = files([