summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..060dd7b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,25 @@
+cmake_minimum_required(VERSION 3.0)
+project(kms++)
+
+IF(NOT CMAKE_BUILD_TYPE)
+ SET(CMAKE_BUILD_TYPE Release CACHE STRING
+ "Choose the type of build, options are: Debug, Release."
+ FORCE)
+ENDIF(NOT CMAKE_BUILD_TYPE)
+
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
+
+set(CMAKE_POSITION_INDEPENDENT_CODE TRUE)
+
+find_package(PkgConfig REQUIRED)
+pkg_check_modules(LIBDRM libdrm REQUIRED)
+
+enable_testing()
+
+add_subdirectory(libkms++)
+add_subdirectory(testpat)
+add_subdirectory(db)
+add_subdirectory(py)
+add_subdirectory(lua)
+