summaryrefslogtreecommitdiff
path: root/py/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2016-03-17 15:07:57 +0200
committerTomi Valkeinen <tomi.valkeinen@ti.com>2016-03-17 15:07:57 +0200
commite43a5d42c1bec57ae874762e179a0d0b645c7e72 (patch)
tree4e375137dd6a68304e88fb23b6e66b20db99b691 /py/CMakeLists.txt
parentc6beb02f3d427b2b46f3e1f5512ef35a072504fb (diff)
Use globbing to add .py test files
Diffstat (limited to 'py/CMakeLists.txt')
-rw-r--r--py/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/py/CMakeLists.txt b/py/CMakeLists.txt
index 1a0738a..f701ef6 100644
--- a/py/CMakeLists.txt
+++ b/py/CMakeLists.txt
@@ -21,7 +21,8 @@ swig_link_libraries(pykms kms++ kmstest ${LIBDRM_LIBRARIES} ${PYTHON_LIBRARIES})
# We get some "maybe-uninitialized" warnings from the generated code. I hope they are harmless.
set_source_files_properties(${swig_generated_file_fullname} PROPERTIES COMPILE_FLAGS "-Wno-maybe-uninitialized")
-add_custom_target(pyextras SOURCES test.py functest.py db.py iact.py)
+file(GLOB PY_SRCS "*.py")
+add_custom_target(pyextras SOURCES ${PY_SRCS})
add_test(NAME pytest COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/functest.py")
set_property(TEST pytest PROPERTY