summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2020-12-01 11:25:52 +0200
committerTomi Valkeinen <tomi.valkeinen@ti.com>2020-12-16 08:58:48 +0200
commitfdffbcdc0b0e63a6ba47d23b662cd992b4f4cede (patch)
tree3c973b6c6d7f08337893b34d89bba8f60b4393f8 /meson.build
parent9f3e29065ea0a39f6032dd1d48b7fb1e5bc12ac5 (diff)
Use system libfmt
libfmt is available on standard PC distros and on buildroot, so lets just use the system provided libfmt instead of a git submodule. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 9652009..8db870c 100644
--- a/meson.build
+++ b/meson.build
@@ -31,9 +31,7 @@ endif
add_global_link_arguments(link_arguments, language : 'cpp')
-libfmt_includes = include_directories('ext/fmt/include')
-libfmt_dep = declare_dependency(include_directories : libfmt_includes,
- compile_args : '-DFMT_HEADER_ONLY')
+libfmt_dep = dependency('fmt')
pybind11_includes = include_directories('ext/pybind11/include')
pybind11_dep = declare_dependency(include_directories : pybind11_includes)