summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2020-10-20 16:34:57 +0300
committerTomi Valkeinen <tomi.valkeinen@ti.com>2020-10-20 16:34:57 +0300
commitcda4a49a95c446be7738ab541008423690144761 (patch)
tree326a7a43235b37a847c459152a8a453c754b0f69 /meson.build
parentdebef007b62bc5e8696e02f96111bd2a10072562 (diff)
meson: add 'util' option to disable kms++util and utils
Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index cd604af..9652009 100644
--- a/meson.build
+++ b/meson.build
@@ -41,8 +41,12 @@ pybind11_dep = declare_dependency(include_directories : pybind11_includes)
libdrmomap_dep = dependency('libdrm_omap', required : get_option('omap'))
subdir('kms++')
-subdir('kms++util')
-subdir('utils')
+
+if get_option('utils')
+ subdir('kms++util')
+ subdir('utils')
+endif
+
subdir('py')
if get_option('kmscube')