summaryrefslogtreecommitdiff
path: root/tests/nouveau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/nouveau/Makefile.am')
-rw-r--r--tests/nouveau/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/nouveau/Makefile.am b/tests/nouveau/Makefile.am
new file mode 100644
index 00000000..c4f6e299
--- /dev/null
+++ b/tests/nouveau/Makefile.am
@@ -0,0 +1,16 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include/drm \
+ -I$(top_srcdir)/nouveau \
+ -I$(top_srcdir)
+
+AM_CFLAGS = $(WARN_CFLAGS)
+
+LDADD = \
+ ../../nouveau/libdrm_nouveau.la \
+ ../../libdrm.la \
+ -ldl -lpthread
+
+TESTS = threaded
+
+check_PROGRAMS = $(TESTS)
+