summaryrefslogtreecommitdiff
path: root/radeon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'radeon/Makefile.am')
-rw-r--r--radeon/Makefile.am22
1 files changed, 4 insertions, 18 deletions
diff --git a/radeon/Makefile.am b/radeon/Makefile.am
index c9695739..aa66ca36 100644
--- a/radeon/Makefile.am
+++ b/radeon/Makefile.am
@@ -22,6 +22,8 @@
# Authors:
# Jérôme Glisse <glisse@freedesktop.org>
+include Makefile.sources
+
AM_CFLAGS = \
$(WARN_CFLAGS) \
$(VISIBILITY_CFLAGS) \
@@ -35,26 +37,10 @@ libdrm_radeon_ladir = $(libdir)
libdrm_radeon_la_LDFLAGS = -version-number 1:0:1 -no-undefined
libdrm_radeon_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
-libdrm_radeon_la_SOURCES = \
- radeon_bo_gem.c \
- radeon_cs_gem.c \
- radeon_cs_space.c \
- radeon_bo.c \
- radeon_cs.c \
- radeon_surface.c \
- bof.c \
- bof.h
+libdrm_radeon_la_SOURCES = $(LIBDRM_RADEON_FILES)
libdrm_radeonincludedir = ${includedir}/libdrm
-libdrm_radeoninclude_HEADERS = \
- radeon_bo.h \
- radeon_cs.h \
- radeon_surface.h \
- radeon_bo_gem.h \
- radeon_cs_gem.h \
- radeon_bo_int.h \
- radeon_cs_int.h \
- r600_pci_ids.h
+libdrm_radeoninclude_HEADERS = $(LIBDRM_RADEON_H_FILES)
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = libdrm_radeon.pc