summaryrefslogtreecommitdiff
path: root/intel/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'intel/Makefile.am')
-rw-r--r--intel/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/intel/Makefile.am b/intel/Makefile.am
index f734b0bf..846695d5 100644
--- a/intel/Makefile.am
+++ b/intel/Makefile.am
@@ -22,6 +22,8 @@
# Authors:
# Eric Anholt <eric@anholt.net>
+include Makefile.sources
+
AM_CFLAGS = \
$(WARN_CFLAGS) \
$(VISIBILITY_CFLAGS) \
@@ -40,22 +42,12 @@ libdrm_intel_la_LIBADD = ../libdrm.la \
@PCIACCESS_LIBS@ \
@CLOCK_LIB@
-libdrm_intel_la_SOURCES = \
- intel_bufmgr.c \
- intel_bufmgr_priv.h \
- intel_bufmgr_fake.c \
- intel_bufmgr_gem.c \
- intel_decode.c \
- intel_chipset.h \
- mm.c \
- mm.h
+libdrm_intel_la_SOURCES = $(LIBDRM_INTEL_FILES)
intel_bufmgr_gem_o_CFLAGS = $(AM_CFLAGS) -c99
libdrm_intelincludedir = ${includedir}/libdrm
-libdrm_intelinclude_HEADERS = intel_bufmgr.h \
- intel_aub.h \
- intel_debug.h
+libdrm_intelinclude_HEADERS = $(LIBDRM_INTEL_H_FILES)
# This may be interesting even outside of "make check", due to the -dump option.
noinst_PROGRAMS = test_decode