summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 76cf91eb..c25a8133 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,21 +403,6 @@ AC_ARG_WITH([kernel-source],
[kernel_source="$with_kernel_source"])
AC_SUBST(kernel_source)
-dnl Add flags for gcc and g++
-if test "x$GCC" = xyes; then
- # Enable -fvisibility=hidden if using a gcc that supports it
- save_CFLAGS="$CFLAGS"
- AC_MSG_CHECKING([whether $CC supports -fvisibility=hidden])
- VISIBILITY_CFLAGS="-fvisibility=hidden"
- CFLAGS="$CFLAGS $VISIBILITY_CFLAGS"
- AC_LINK_IFELSE([AC_LANG_PROGRAM()], AC_MSG_RESULT([yes]),
- [VISIBILITY_CFLAGS=""; AC_MSG_RESULT([no])]);
-
- # Restore CFLAGS; VISIBILITY_CFLAGS are added to it where needed.
- CFLAGS=$save_CFLAGS
- AC_SUBST([VISIBILITY_CFLAGS])
-fi
-
AC_MSG_CHECKING([whether $CC supports __attribute__((visibility))])
AC_LINK_IFELSE([AC_LANG_PROGRAM([
int foo_default( void ) __attribute__((visibility("default")));