summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-03-31 22:07:13 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-04-28 11:19:15 +0100
commit104c895f650cac7741c12e10ee78bb2fca2cbd49 (patch)
tree3cff71d287b5b1a0276782ba8b5862848b786f7d /configure.ac
parent42465feb9759ef5a6d79d7e628510cd0a081f913 (diff)
drm: remove no longer needed VISIBILITY_CFLAGS
With earlier commits we've annotated the private symbols, thus we no longer require the -fvisibility=hidden CFLAGS. Cc: Ben Skeggs <bskeggs@redhat.com> Cc: Damien Lespiau <damien.lespiau@intel.com> Cc: Maarten Lankhorst <maarten.lankhorst@canonical.com> Cc: Michel Dänzer <michel.daenzer@amd.com> Cc: Rob Clark <robdclark@gmail.com> Cc: Thierry Reding <treding@nvidia.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 76cf91eb..c25a8133 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,21 +403,6 @@ AC_ARG_WITH([kernel-source],
[kernel_source="$with_kernel_source"])
AC_SUBST(kernel_source)
-dnl Add flags for gcc and g++
-if test "x$GCC" = xyes; then
- # Enable -fvisibility=hidden if using a gcc that supports it
- save_CFLAGS="$CFLAGS"
- AC_MSG_CHECKING([whether $CC supports -fvisibility=hidden])
- VISIBILITY_CFLAGS="-fvisibility=hidden"
- CFLAGS="$CFLAGS $VISIBILITY_CFLAGS"
- AC_LINK_IFELSE([AC_LANG_PROGRAM()], AC_MSG_RESULT([yes]),
- [VISIBILITY_CFLAGS=""; AC_MSG_RESULT([no])]);
-
- # Restore CFLAGS; VISIBILITY_CFLAGS are added to it where needed.
- CFLAGS=$save_CFLAGS
- AC_SUBST([VISIBILITY_CFLAGS])
-fi
-
AC_MSG_CHECKING([whether $CC supports __attribute__((visibility))])
AC_LINK_IFELSE([AC_LANG_PROGRAM([
int foo_default( void ) __attribute__((visibility("default")));