summaryrefslogtreecommitdiff
path: root/tests/tegra/Makefile.am
diff options
context:
space:
mode:
authorThierry Reding <treding@nvidia.com>2014-02-19 14:48:31 +0100
committerThierry Reding <treding@nvidia.com>2014-11-27 17:20:27 +0100
commit93035cfbebf1344a041b70fbf9f3b89f6542805f (patch)
tree1b5daee7de436e3569d494c6ab9adfdfcad2fd23 /tests/tegra/Makefile.am
parentd6a4c2cbd11e357a9123f6d41f6d40d38e82e7f2 (diff)
tegra: Add simple test for drm_tegra_open()
This test opens a device, dumps the version information and checks that a Tegra DRM context can be opened on it. Signed-off-by: Thierry Reding <treding@nvidia.com>
Diffstat (limited to 'tests/tegra/Makefile.am')
-rw-r--r--tests/tegra/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/tegra/Makefile.am b/tests/tegra/Makefile.am
new file mode 100644
index 00000000..ca63d92f
--- /dev/null
+++ b/tests/tegra/Makefile.am
@@ -0,0 +1,13 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include/drm \
+ -I$(top_srcdir)/tegra \
+ -I$(top_srcdir)
+
+AM_CFLAGS = -Wall -Werror
+
+LDADD = \
+ ../../tegra/libdrm_tegra.la \
+ ../../libdrm.la
+
+noinst_PROGRAMS = \
+ openclose