summaryrefslogtreecommitdiff
path: root/tests/modetest/Makefile.am
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2014-12-09 22:00:58 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2015-01-11 14:37:53 +0200
commitd7c0a08bc576deb07df6c3f91f393ca8edd0c4bf (patch)
tree8655e690adaeb888110ef392abf799c3217871e2 /tests/modetest/Makefile.am
parent566c3ce877a4be72697e15cdfc421ce965f7c37d (diff)
modetest: Allocate dumb buffers with the correct bpp
The modetest application uses libkms to allocate dumb buffers, leading to overallocation due to the hardcoded 32 bpp value. This can even cause failures in drivers when the resulting pitch is too large for the hardware to handle and gets rejected by the driver when creating the frame buffer. Fix this by computing the required bpp value and allocating dumb buffers directly without going through libkms. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'tests/modetest/Makefile.am')
-rw-r--r--tests/modetest/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/tests/modetest/Makefile.am b/tests/modetest/Makefile.am
index 8fc924a3..93820fac 100644
--- a/tests/modetest/Makefile.am
+++ b/tests/modetest/Makefile.am
@@ -4,7 +4,6 @@ AM_CFLAGS = $(filter-out -Wpointer-arith, $(WARN_CFLAGS))
AM_CFLAGS += \
-I$(top_srcdir)/include/drm \
- -I$(top_srcdir)/libkms/ \
-I$(top_srcdir)
if HAVE_INSTALL_TESTS
@@ -19,7 +18,6 @@ modetest_SOURCES = $(MODETEST_FILES)
modetest_LDADD = \
$(top_builddir)/libdrm.la \
- $(top_builddir)/libkms/libkms.la \
-lpthread
if HAVE_CAIRO