summaryrefslogtreecommitdiff
path: root/tests/modetest/Makefile.am
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2013-02-11 21:36:30 +0100
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2013-08-05 14:21:43 +0200
commitca9c8f06e0f560082dcd0943e9be29ba9a915ee3 (patch)
tree8722c056cb3c39499ba08a27fb5bba27ebe0bbd4 /tests/modetest/Makefile.am
parent6e8f868e034531b66a215e4e6d978b43b58b92d0 (diff)
modetest: Fix warnings
Enable all standard automake warnings except for -Wpointer-arith (as the test pattern generation code uses void pointer arithmetics) and fix them. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'tests/modetest/Makefile.am')
-rw-r--r--tests/modetest/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/modetest/Makefile.am b/tests/modetest/Makefile.am
index 410c6326..6e7ff14f 100644
--- a/tests/modetest/Makefile.am
+++ b/tests/modetest/Makefile.am
@@ -1,4 +1,6 @@
-AM_CFLAGS = \
+AM_CFLAGS = $(filter-out -Wpointer-arith, $(WARN_CFLAGS))
+
+AM_CFLAGS += \
-I$(top_srcdir)/include/drm \
-I$(top_srcdir)/libkms/ \
-I$(top_srcdir)