summaryrefslogtreecommitdiff
path: root/radeon/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2009-12-17 14:11:55 +1000
committerDave Airlie <airlied@redhat.com>2009-12-21 08:05:16 +1000
commit125994ab30d4f0f126c62fa741ec62a52d69d7a8 (patch)
treee641a13ec8e32c2322ebe1f1480581d58ad815e8 /radeon/Makefile.am
parentf1660c249198b5cc14ebbb75107da7bcb6972033 (diff)
radeon: straighten out the API insanity.
as Michel pointed out we are exposing too much info for these object for this to be maintainable going forward. This patch set minimises the exposed parts of the radeon_bo and radeon_cs objects to the piece necessary for ddx/mesa to operate at a decent speed. The major problem is mesa contains a legacy BO/CS managers which we still need to expose functionality to, and we really cannot change the API until we can drop the non-KMS codepaths. Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'radeon/Makefile.am')
-rw-r--r--radeon/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/radeon/Makefile.am b/radeon/Makefile.am
index dd136b1f..29af1df2 100644
--- a/radeon/Makefile.am
+++ b/radeon/Makefile.am
@@ -38,7 +38,8 @@ libdrm_radeon_la_SOURCES = \
radeon_bo_gem.c \
radeon_cs_gem.c \
radeon_cs_space.c \
- radeon_track.c
+ radeon_bo.c \
+ radeon_cs.c
libdrm_radeonincludedir = ${includedir}/drm
libdrm_radeoninclude_HEADERS = \
@@ -46,7 +47,8 @@ libdrm_radeoninclude_HEADERS = \
radeon_cs.h \
radeon_bo_gem.h \
radeon_cs_gem.h \
- radeon_track.h
+ radeon_bo_int.h \
+ radeon_cs_int.h
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = libdrm_radeon.pc