summaryrefslogtreecommitdiff
path: root/libdrm/intel/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2008-06-12 23:22:26 -0700
committerDave Airlie <airlied@linux.ie>2008-10-17 06:38:57 +1000
commit6df7b0719fe92b718e486c2b87e2f883cfa41efa (patch)
treec0a48d61bf6dd496d2ecaee2adc1eb111f40466e /libdrm/intel/Makefile.am
parent26076bf24a4e720e389d0a3ea616a8350397fdfc (diff)
intel: Protect bufmgr objects with a pthread mutex.
We want to be able to use the bufmgr from multiple threads for GL, and thus we need to protect the internal structures. The pthread-stubs package is used so that programs not linked against pthreads get weak symbols to stubs and don't eat most of the cost.
Diffstat (limited to 'libdrm/intel/Makefile.am')
-rw-r--r--libdrm/intel/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libdrm/intel/Makefile.am b/libdrm/intel/Makefile.am
index 607c4765..92388c24 100644
--- a/libdrm/intel/Makefile.am
+++ b/libdrm/intel/Makefile.am
@@ -26,6 +26,7 @@ AM_CFLAGS = \
$(WARN_CFLAGS) \
-I$(top_srcdir)/libdrm \
-I$(top_srcdir)/libdrm/intel \
+ $(PTHREADSTUBS_CFLAGS) \
-I$(top_srcdir)/shared-core
libdrm_intel_la_LTLIBRARIES = libdrm_intel.la