summaryrefslogtreecommitdiff
path: root/intel/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2012-01-03 14:32:18 -0800
committerEric Anholt <eric@anholt.net>2012-01-04 14:49:44 -0800
commit683855f65523c978562ead56f9d68f50ffdca1a2 (patch)
tree078e74f9858d18f63d55d23ce3592a15ddfc540d /intel/Makefile.am
parentccbc40340b7b472939a90ae8afc0a82b358ce189 (diff)
intel: Add regression tests for batch decode.
The .batch was generated using the dump-a-batch branch of git://people.freedesktop.org/~anholt/mesa using glxgears on gen7 hardware, using INTEL_DEVID_OVERRIDE for non-gen7 (this means that offsets in the buffers for non-gen7 are 0!). The .ref was generated by: ./test_decode tests/gen7-3d.batch -dump. The .sh exists because you can't supply arguments to tests using the simple automake tests driver. Something reasonable could be done using automake's parallel-tests driver (in fact, a previous version of the patch did that), but I was concerned that: 1) The parallel-tests driver is documented to be unstable -- they may change interfaces on us later. 2) The parallel-tests driver hides the output of tests in .log files scattered all over the tree, which was ugly and more painful to work with. v2: Actually add the batch files, add a .gitignore for the *-new.txt files added after failures, and fix failure mode for undetected chipset name. Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch> (v1)
Diffstat (limited to 'intel/Makefile.am')
-rw-r--r--intel/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/intel/Makefile.am b/intel/Makefile.am
index 2d3d8c4c..581c8c0d 100644
--- a/intel/Makefile.am
+++ b/intel/Makefile.am
@@ -57,6 +57,23 @@ libdrm_intelinclude_HEADERS = intel_bufmgr.h \
# This may be interesting even outside of "make check", due to the -dump option.
noinst_PROGRAMS = test_decode
+BATCHES = \
+ tests/gen4-3d.batch \
+ tests/gm45-3d.batch \
+ tests/gen5-3d.batch \
+ tests/gen6-3d.batch \
+ tests/gen7-3d.batch
+
+TESTS = \
+ $(BATCHES:.batch=.batch.sh)
+
+EXTRA_DIST = \
+ $(BATCHES) \
+ $(BATCHES:.batch=.batch.sh) \
+ $(BATCHES:.batch=.batch-ref.txt) \
+ $(BATCHES:.batch=.batch-ref.txt) \
+ tests/test-batch.sh
+
test_decode_LDADD = libdrm_intel.la
pkgconfig_DATA = libdrm_intel.pc