summaryrefslogtreecommitdiff
path: root/intel/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2011-10-11 15:59:03 -0700
committerEric Anholt <eric@anholt.net>2012-03-09 16:34:14 -0800
commit4db16a9480af2c4f36eb8023193cd54545efbe54 (patch)
tree4635807428852255ae846d4a9f15184e7bd88af3 /intel/Makefile.am
parent6e642db7f4a5628ed63ca3c479f06bd6f2ca3893 (diff)
intel: Add .aub file output support.
This will allow the driver to capture all of its execution state to a file for later debugging. intel_gpu_dump is limited in that it only captures batchbuffers, and Mesa's captures, while more complete, still capture only a portion of the state involved in execution. This is a squash commit of a long series of hacking as we tried to get the resulting traces to work in the internal simulator. It contains contributions by Yuanhan Liu and Kenneth Graunke. v2: Drop the MI_FLUSH_ENABLE setup. Reviewed-by: Kenneth Graunke <kenneth@whitecape.org> Signed-off-by: Eric Anholt <eric@anholt.net> Signed-off-by: Yuanhan Liu <yuanhan.liu@linux.intel.com> Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'intel/Makefile.am')
-rw-r--r--intel/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/intel/Makefile.am b/intel/Makefile.am
index 06362b69..dc01a96d 100644
--- a/intel/Makefile.am
+++ b/intel/Makefile.am
@@ -53,6 +53,7 @@ intel_bufmgr_gem_o_CFLAGS = $(AM_CFLAGS) -c99
libdrm_intelincludedir = ${includedir}/libdrm
libdrm_intelinclude_HEADERS = intel_bufmgr.h \
+ intel_aub.h \
intel_debug.h
# This may be interesting even outside of "make check", due to the -dump option.