summaryrefslogtreecommitdiff
path: root/exynos/Makefile.am
diff options
context:
space:
mode:
authorInki Dae <inki.dae@samsung.com>2012-05-04 19:13:14 +0900
committerRob Clark <rob@ti.com>2012-05-12 10:04:54 -0500
commite07b650662ea0529d99741691c47856ef1034c9c (patch)
tree0f465d978c9316abcc223e3c51c042c7103ea16d /exynos/Makefile.am
parent86451a12ca52e88a9600ed55f56b8cacd1ac0d6d (diff)
libdrm: add exynos drm support
this patch adds libdrm_exynos helper layer that inclues some intefaces for exynos specific gem and virtual display driver and also adds exynos module name to modtest and vbltest. Changelog v2: - fixed exynos broken ioctl. the pointer of uint64_t *edid should be removed. - removed unnecessary definitions. - added drm prime interfaces. this feature is used to share a buffer between drivers or memory managers and for this, please, refer to below links: http://www.mjmwired.net/kernel/Documentation/dma-buf-sharing.txt http://lwn.net/Articles/488664/ this patch is based on a link below: git://anongit.freedesktop.org/mesa/drm commit id: d72a44c7c4f5eea9c1e5bb0c36cb9e0224b9ca22 Reviewed-by: Rob Clark <rob@ti.com> Reviewed-by: Alex Deucher <alexander.deucher@amd.com> Signed-off-by: Inki Dae <inki.dae@samsung.com> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> Signed-off-by: Rob Clark <rob@ti.com>
Diffstat (limited to 'exynos/Makefile.am')
-rw-r--r--exynos/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/exynos/Makefile.am b/exynos/Makefile.am
new file mode 100644
index 00000000..e782d34d
--- /dev/null
+++ b/exynos/Makefile.am
@@ -0,0 +1,22 @@
+AM_CFLAGS = \
+ $(WARN_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/exynos \
+ $(PTHREADSTUBS_CFLAGS) \
+ -I$(top_srcdir)/include/drm
+
+libdrm_exynos_la_LTLIBRARIES = libdrm_exynos.la
+libdrm_exynos_ladir = $(libdir)
+libdrm_exynos_la_LDFLAGS = -version-number 1:0:0 -no-undefined
+libdrm_exynos_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
+
+libdrm_exynos_la_SOURCES = exynos_drm.c
+
+libdrm_exynoscommonincludedir = ${includedir}/exynos
+libdrm_exynoscommoninclude_HEADERS = exynos_drm.h
+
+libdrm_exynosincludedir = ${includedir}/libdrm
+libdrm_exynosinclude_HEADERS = exynos_drmif.h
+
+pkgconfigdir = @pkgconfigdir@
+pkgconfig_DATA = libdrm_exynos.pc