summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2012-01-30 15:20:04 -0800
committerJeremy Huddleston <jeremyhu@apple.com>2012-01-30 15:20:04 -0800
commitefd6e81e2ba112105457887ae18a58dfa4bbc8ef (patch)
treea7f82933d303c17d7ca9e1299c3815b6b29ec61c /configure.ac
parent592ac67626f6d69bd8b518a33e80e9c4d223eba2 (diff)
Don't build Intel DRM if $CHOST is not i?86-* or x86_64-*
This fixes a failure in 'make check' found by the tinderbox when trying to build this code on Linux/ppc. This code is only designed to run on Intel platforms, so don't even bother building it if we're not in that set. Found-by: Tinderbox Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 773167f5..f5ebc1d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,7 +250,10 @@ if test "x$INTEL" != "xno" -o "x$RADEON" != "xno"; then
else
if test "x$INTEL" != "xno"; then
- INTEL=yes
+ case $host_os in
+ i?86-*|x86_64-*) INTEL=yes ;;
+ *) INTEL=no ;;
+ esac
fi
if test "x$RADEON" != "xno"; then
RADEON=yes