summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaarten Lankhorst <maarten.lankhorst@ubuntu.com>2015-01-21 11:46:04 +0100
committerMaarten Lankhorst <maarten.lankhorst@ubuntu.com>2015-01-21 11:47:13 +0100
commitd5bfbdc62ffc3eee4beabc84e78f47970eb9dbae (patch)
tree8d80e7806155442921b1964660c2d6adb5c06081 /configure.ac
parenteca91cf163d50090db36d0b2abbffcff813a2adf (diff)
only enable support for freedreno on arm automatically
Users can still override this by explicitly passing --enable-freedreno to configure. Signed-off-by: Maarten Lankhorst <maarten.lankhorst@ubuntu.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c0ab4302..8422de94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,8 +95,8 @@ AC_ARG_ENABLE(exynos-experimental-api,
AC_ARG_ENABLE(freedreno,
AS_HELP_STRING([--disable-freedreno],
- [Enable support for freedreno's KMS API (default: enabled)]),
- [FREEDRENO=$enableval], [FREEDRENO=yes])
+ [Enable support for freedreno's KMS API (default: enabled on arm)]),
+ [FREEDRENO=$enableval], [FREEDRENO=auto])
AC_ARG_ENABLE(freedreno-kgsl,
AS_HELP_STRING([--enable-freedreno-kgsl],
@@ -277,6 +277,13 @@ if test "x$LIBKMS" = xauto ; then
esac
fi
+if test "x$FREEDRENO" = xauto ; then
+ case $host_cpu in
+ arm*|aarch64) FREEDRENO="yes" ;;
+ *) FREEDRENO="no" ;;
+ esac
+fi
+
AM_CONDITIONAL(HAVE_LIBKMS, [test "x$LIBKMS" = xyes])
AM_CONDITIONAL(HAVE_INTEL, [test "x$INTEL" = xyes])