summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@nwnk.net>2005-07-10 22:42:42 +0000
committerAdam Jackson <ajax@nwnk.net>2005-07-10 22:42:42 +0000
commit07d23f9c60f9358f064eab7d944f3b28484b51ef (patch)
tree9687b5ed89314ad30a1939c6462ab5d6df0d4303 /configure.ac
parent04fea060023a539c6c6766ec184b59f32c97d474 (diff)
autoconfiscate libdrm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 46 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 00000000..4fb505df
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,46 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AC_PREREQ(2.57)
+AC_INIT([libdrm], 1.0.0, [dri-devel@lists.sourceforge.net], libdrm)
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AM_CONFIG_HEADER([libdrm/config.h])
+
+AC_PROG_LIBTOOL
+AC_PROG_CC
+
+AC_HEADER_STDC
+
+AC_ARG_ENABLE(system, AC_HELP_STRING([--enable-system],
+ [Configure to be the system libdrm]),
+ [SYSTEM=$enableval], [SYSTEM=no])
+AM_CONDITIONAL(SYSTEM, [test x$SYSTEM = xyes])
+if test x$SYSTEM = xyes; then
+ libdir=/lib
+ includedir=/usr/include
+ pkgconfigdir=/usr/lib/pkgconfig
+else
+ pkgconfigdir=${libdir}/pkgconfig
+fi
+AC_SUBST(pkgconfigdir)
+
+AC_OUTPUT([Makefile libdrm/Makefile libdrm.pc])