summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-04-06 19:02:38 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-04-28 11:21:10 +0100
commite2b531866f9be4b3b1dd9b42f7dda816183792b0 (patch)
treea853ea567534d2d24c9cca53b63a1d0c8d39109d /Makefile.am
parent41eb131dfe1b8c03cda6e271496bcb7729e58fb6 (diff)
man: rework the Makefile.am
Remove GNU make specific constructs and take into consideration that Solaris man 7 is not the same as Linux man 7. This commit introduces a dependency of xorg-macros 1.12 (released 4+ years ago) which is used to handle the above man section discrepancies. Cc: Niveditha Rau <niveditha.rau@oracle.com> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 42d3d7f0..13df80c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,6 +73,12 @@ if HAVE_TEGRA
TEGRA_SUBDIR = tegra
endif
+if BUILD_MANPAGES
+if HAVE_MANPAGES_STYLESHEET
+MAN_SUBDIR = man
+endif
+endif
+
SUBDIRS = \
. \
$(LIBKMS_SUBDIR) \
@@ -84,7 +90,7 @@ SUBDIRS = \
$(FREEDRENO_SUBDIR) \
$(TEGRA_SUBDIR) \
tests \
- man
+ $(MAN_SUBDIR)
libdrm_la_LTLIBRARIES = libdrm.la
libdrm_ladir = $(libdir)