summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-12-28 22:06:51 -0800
committerKenneth Graunke <kenneth@whitecape.org>2014-01-20 10:58:06 -0800
commit734de7093db296912da0027e4fa1094f60787c11 (patch)
tree81548f2353d24b0a90cd5da7f4dedcfbc7d2be08 /Makefile.am
parentcb4bc8ead63cb213a26bcc8d14b2b44d9fb967da (diff)
drm: Initialize or valgrind-clear modesetting ioctl arguments.
Fixes valgrind complaints in the modesetting driver. I tried to follow each ioctl's pattern for whether it was initializing just the in values, or both in and out values. Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f7260368..826c30d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -59,6 +59,8 @@ libdrm_la_LDFLAGS = -version-number 2:4:0 -no-undefined
libdrm_la_LIBADD = @CLOCK_LIB@
libdrm_la_CPPFLAGS = -I$(top_srcdir)/include/drm
+AM_CFLAGS = \
+ $(VALGRIND_CFLAGS)
libdrm_la_SOURCES = \
xf86drm.c \