summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThierry Reding <treding@nvidia.com>2014-02-19 15:56:50 +0100
committerThierry Reding <treding@nvidia.com>2014-07-30 16:58:14 +0200
commit5d8357976a84396ebe10ed5a0d6ba1b79ccdcf2e (patch)
tree5986dd94ff3b108a5aa9fd7fdb51f9656200ed7e /Makefile.am
parentd6861609b2b887612d652bb2be7c39f199802937 (diff)
configure: Support symbol visibility when available
Checks whether or not the compiler supports the -fvisibility option. If so it sets the VISIBILITY_CFLAGS variable which can be added to the per directory AM_CFLAGS where appropriate. By default all symbols will be hidden via the VISIBILITY_CFLAGS. The drm_public macro can be used to mark symbols that should be exported. Reviewed-by: Maarten Lankhorst <maarten.lankhorst@canonical.com> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> Signed-off-by: Thierry Reding <treding@nvidia.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 826c30d0..65680da9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,7 @@ libdrm_la_SOURCES = \
xf86drmSL.c \
xf86drmMode.c \
xf86atomic.h \
+ libdrm.h \
libdrm_lists.h
libdrmincludedir = ${includedir}