summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-05-30 14:25:08 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-06-29 11:12:21 +0100
commit5b0e76f143887c4ec7db45c54a7ba27a58f59227 (patch)
treee400f3b7878b59f590d81ca783e16904da189cb0 /Makefile.am
parent203983f842a889b279698fdea46e83ee4450a1db (diff)
Revert "Add device enumeration interface (v4)"
This reverts commit fde4969176822fe54197b6baa78f8b0ef900baba. The commit adds an API that does not seem flexible enough to be used in current open-source projects. Additionally it adds a hidden dependency of libudev, which when used in mesa caused grief when combined with Steam('s runtime). Let's revert this for now and add a tweaked API later on that can be used in mesa/xserver. Cc: Frank Min <frank.min@amd.com> Cc: Christian König <christian.koenig@amd.com> Cc: Alex Deucher <alexander.deucher@amd.com> Cc: Jammy Zhou <Jammy.Zhou@amd.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index ffd334ad..13df80c5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -95,15 +95,12 @@ SUBDIRS = \
libdrm_la_LTLIBRARIES = libdrm.la
libdrm_ladir = $(libdir)
libdrm_la_LDFLAGS = -version-number 2:4:0 -no-undefined
-libdrm_la_LIBADD = \
- @CLOCK_LIB@ \
- @LIBUDEV_LIBS@
+libdrm_la_LIBADD = @CLOCK_LIB@
libdrm_la_CPPFLAGS = -I$(top_srcdir)/include/drm
AM_CFLAGS = \
$(WARN_CFLAGS) \
- $(VALGRIND_CFLAGS) \
- $(LIBUDEV_CFLAGS)
+ $(VALGRIND_CFLAGS)
libdrm_la_SOURCES = $(LIBDRM_FILES)