summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-02-23 12:52:47 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-02-27 15:51:24 +0000
commit4c6b1b1a825a01cb64451306bbebd61927442bb0 (patch)
treee41eb6c3a5c07e52e4173df61cd83b586b578be9 /Makefile.am
parent794810d62d49c05a9b06c8570a6b668b4bb0179d (diff)
autotools: add WARN_CFLAGS to all targets
... minus test/ttmtest. The latter is not really hooked up with the actual build. This will give us 66 warnings on a distribution build of which - 12 -Wunused-variable - 11 -Wunused-function - 19 -Wmissing-prototypes and a few -Wswitch-enum, -Wtype-limits etc. Adding the CFLAGS gives some exposure to these so that we can fix them. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Jan Vesely <jan.vesely@rutgers.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 062feb42..9514cc59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,6 +82,7 @@ libdrm_la_LIBADD = @CLOCK_LIB@
libdrm_la_CPPFLAGS = -I$(top_srcdir)/include/drm
AM_CFLAGS = \
+ $(WARN_CFLAGS) \
$(VALGRIND_CFLAGS)
libdrm_la_SOURCES = $(LIBDRM_FILES)