summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-02-23 13:10:56 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2015-02-27 15:49:20 +0000
commit0dec5e14cff899d256c905c920f2a10d8eb6c55a (patch)
treea7f60e0ccd0d57a322465bbfbbf674a35f912a87 /Makefile.am
parent77703f61cb51350c12bb85db1a7296fa50839edb (diff)
autotools: add AM_DISTCHECK_CONFIGURE_FLAGS
To make sure that the release/distribution tarball is not broken for all the targets. Currently the experimental APIs are disabled by default amongst others. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Jan Vesely <jan.vesely@rutgers.edu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3cb516c8..062feb42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,22 @@ include Makefile.sources
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --enable-udev \
+ --enable-libkms \
+ --enable-intel \
+ --enable-radeon \
+ --enable-nouveau \
+ --enable-vmwgfx \
+ --enable-omap-experimental-api \
+ --enable-exynos-experimental-api \
+ --enable-freedreno \
+ --enable-freedreno-kgsl\
+ --enable-tegra-experimental-api \
+ --enable-install-test-programs \
+ --enable-cairo-tests \
+ --enable-manpages
+
pkgconfigdir = @pkgconfigdir@
pkgconfig_DATA = libdrm.pc