summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 10f54e31..75fc2413 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -35,6 +35,9 @@ if HAVE_NOUVEAU
SUBDIRS += nouveau
endif
+TESTS = \
+ drmsl
+
if HAVE_LIBUDEV
check_LTLIBRARIES = libdrmtest.la
@@ -52,7 +55,7 @@ XFAIL_TESTS = \
auth \
lock
-TESTS = \
+TESTS += \
openclose \
getversion \
getclient \
@@ -60,7 +63,6 @@ TESTS = \
setversion \
updatedraw \
name_from_fd
+endif
check_PROGRAMS += $(TESTS)
-
-endif