summaryrefslogtreecommitdiff
path: root/freedreno/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'freedreno/Makefile.am')
-rw-r--r--freedreno/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/freedreno/Makefile.am b/freedreno/Makefile.am
new file mode 100644
index 00000000..f46a7807
--- /dev/null
+++ b/freedreno/Makefile.am
@@ -0,0 +1,19 @@
+AM_CFLAGS = \
+ $(WARN_CFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/freedreno \
+ $(PTHREADSTUBS_CFLAGS) \
+ -I$(top_srcdir)/include/drm
+
+libdrm_freedreno_la_LTLIBRARIES = libdrm_freedreno.la
+libdrm_freedreno_ladir = $(libdir)
+libdrm_freedreno_la_LDFLAGS = -version-number 1:0:0 -no-undefined
+libdrm_freedreno_la_LIBADD = ../libdrm.la @PTHREADSTUBS_LIBS@
+
+libdrm_freedreno_la_SOURCES = freedreno_device.c freedreno_pipe.c freedreno_ringbuffer.c freedreno_bo.c
+
+libdrm_freedrenocommonincludedir = ${includedir}/freedreno
+libdrm_freedrenocommoninclude_HEADERS = freedreno_drmif.h freedreno_ringbuffer.h
+
+pkgconfigdir = @pkgconfigdir@
+pkgconfig_DATA = libdrm_freedreno.pc