summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2009-04-06 17:13:01 -0400
committerKristian Høgsberg <krh@redhat.com>2009-04-06 17:13:01 -0400
commite9d6116e5bd30639d6333ef95462fe300f47ccd5 (patch)
treef704c598394685cffea66bf6bdccf88a1b6ea96e /tests/Makefile.am
parent51d6346f9f3c425f49e57d185530c6bcaeb94f5e (diff)
Use libudev in test case to only run gem tests for intel devices.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e66d1c82..123c5478 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -6,19 +6,22 @@ noinst_PROGRAMS = \
dristat \
drmstat
+SUBDIRS = \
+ modeprint \
+ modetest
+
+if HAVE_LIBUDEV
+
EXTRA_LTLIBRARIES = libdrmtest.la
libdrmtest_la_SOURCES = \
drmtest.c \
drmtest.h
libdrmtest_la_LIBADD = \
- $(top_builddir)/libdrm/libdrm.la
+ $(top_builddir)/libdrm/libdrm.la \
+ $(LIBUDEV_LIBS)
LDADD = libdrmtest.la
-SUBDIRS = \
- modeprint \
- modetest
-
TESTS = auth \
openclose \
getversion \
@@ -33,5 +36,8 @@ TESTS = auth \
gem_mmap
EXTRA_PROGRAMS = $(TESTS)
+
+endif
+
CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)