summaryrefslogtreecommitdiff
path: root/intel/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-02-09 10:23:10 +0000
committerChris Wilson <chris@chris-wilson.co.uk>2012-02-11 11:45:39 +0000
commit90b23cc24c19fbe131d84237c55311cafeb4ca21 (patch)
tree0162fe16b86dc102fd5f75e2e3e7ce8c83858ea7 /intel/Makefile.am
parent2cfac57d364d0166ed9472b086c16aea376f495a (diff)
intel: Mark up with valgrind intrinsics to reduce false positives
In particular, declare the hidden CPU mmaps to valgrind so that it knows about those memory regions. v2: Add an additional VG_CLEAR for the getparam References: https://bugs.freedesktop.org/show_bug.cgi?id=35071 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Acked-by: Ben Widawsky <ben@bwidawsk.net> [anholt: Ideally valgrind should just learn about the ioctls, and removing the clear for the non-valgrindified code feels risky.] Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'intel/Makefile.am')
-rw-r--r--intel/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/intel/Makefile.am b/intel/Makefile.am
index 7225a78d..06362b69 100644
--- a/intel/Makefile.am
+++ b/intel/Makefile.am
@@ -28,6 +28,7 @@ AM_CFLAGS = \
-I$(top_srcdir)/intel \
$(PTHREADSTUBS_CFLAGS) \
$(PCIACCESS_CFLAGS) \
+ $(VALGRIND_CFLAGS) \
-I$(top_srcdir)/include/drm
libdrm_intel_la_LTLIBRARIES = libdrm_intel.la