summaryrefslogtreecommitdiff
path: root/data/frames/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'data/frames/meson.build')
-rw-r--r--data/frames/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/data/frames/meson.build b/data/frames/meson.build
new file mode 100644
index 0000000..f4ec8e3
--- /dev/null
+++ b/data/frames/meson.build
@@ -0,0 +1,28 @@
+# SPDX-License-Identifier: CC0-1.0
+
+gen_lut = find_program('./gen-lut.py')
+gzip = find_program('gzip')
+
+tables = [
+ ['clu', 'identity'],
+ ['clu', 'wave'],
+ ['clu', 'zero'],
+ ['lut', 'gamma'],
+ ['lut', 'identity'],
+ ['lut', 'zero'],
+]
+
+foreach table : tables
+ name = '@0@-@1@.bin'.format(table[0], table[1])
+ custom_target(output : name,
+ command : [gen_lut, '-o', '@OUTPUT@', '-t', table[0], table[1]],
+ install : true,
+ install_dir : 'frames')
+endforeach
+
+custom_target(input : files('frame-reference-1024x768.pnm.gz'),
+ output : 'frame-reference-1024x768.pnm',
+ capture : true,
+ command : [gzip, '-cd', '@INPUT@'],
+ install : true,
+ install_dir : 'frames')