summaryrefslogtreecommitdiff
path: root/data/frames/meson.build
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2025-04-04 03:12:26 +0300
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2025-04-04 03:32:30 +0300
commitce2c37356c674e5893f80786616355b4659b43ad (patch)
tree8da7297a20bcee66f73eaddcd42a84483a0b30d1 /data/frames/meson.build
parenta4c13e7ce77b86cf36bc6b0a79220b97f8b2a1b8 (diff)
Convert from make to meson
Meson makes cross compilation easier. Replace the make-based build system with meson. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'data/frames/meson.build')
-rw-r--r--data/frames/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/data/frames/meson.build b/data/frames/meson.build
new file mode 100644
index 0000000..f4ec8e3
--- /dev/null
+++ b/data/frames/meson.build
@@ -0,0 +1,28 @@
+# SPDX-License-Identifier: CC0-1.0
+
+gen_lut = find_program('./gen-lut.py')
+gzip = find_program('gzip')
+
+tables = [
+ ['clu', 'identity'],
+ ['clu', 'wave'],
+ ['clu', 'zero'],
+ ['lut', 'gamma'],
+ ['lut', 'identity'],
+ ['lut', 'zero'],
+]
+
+foreach table : tables
+ name = '@0@-@1@.bin'.format(table[0], table[1])
+ custom_target(output : name,
+ command : [gen_lut, '-o', '@OUTPUT@', '-t', table[0], table[1]],
+ install : true,
+ install_dir : 'frames')
+endforeach
+
+custom_target(input : files('frame-reference-1024x768.pnm.gz'),
+ output : 'frame-reference-1024x768.pnm',
+ capture : true,
+ command : [gzip, '-cd', '@INPUT@'],
+ install : true,
+ install_dir : 'frames')