summaryrefslogtreecommitdiff
path: root/py/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'py/tests/CMakeLists.txt')
-rw-r--r--py/tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/py/tests/CMakeLists.txt b/py/tests/CMakeLists.txt
new file mode 100644
index 0000000..a670ed9
--- /dev/null
+++ b/py/tests/CMakeLists.txt
@@ -0,0 +1,7 @@
+file(GLOB PY_SRCS "*.py")
+add_custom_target(pyextras SOURCES ${PY_SRCS})
+
+add_test(NAME pytest COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/functest.py")
+set_property(TEST pytest PROPERTY
+ ENVIRONMENT "PYTHONPATH=." "LD_LIBRARY_PATH=."
+)