summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05ee49e..539c219 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,7 @@ ENDIF(NOT CMAKE_BUILD_TYPE)
set(LIBKMS_ENABLE_PYTHON ON CACHE BOOL "Enable Python wrappers")
set(LIBKMS_ENABLE_LUA OFF CACHE BOOL "Enable Lua wrappers")
+set(LIBKMS_ENABLE_KMSCUBE OFF CACHE BOOL "Enable kmscube")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
@@ -26,6 +27,10 @@ add_subdirectory(libkms++)
add_subdirectory(libkmstest)
add_subdirectory(tests)
+if(LIBKMS_ENABLE_KMSCUBE)
+add_subdirectory(kmscube)
+endif()
+
if(LIBKMS_ENABLE_PYTHON)
add_subdirectory(py)
endif()