summaryrefslogtreecommitdiff
path: root/py/pykms/CMakeLists.txt
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2017-01-02 16:42:09 +0200
committerTomi Valkeinen <tomi.valkeinen@ti.com>2017-01-03 10:46:42 +0200
commitf1a098203be8c44a52ed5d2a72982a3f634d4df6 (patch)
treec916f481fb22a3002d56541346b15532fe46da83 /py/pykms/CMakeLists.txt
parentb11baff09f78a4a383f817ec35208ae8966ab832 (diff)
py: Move helpers to the pykms module
Instead of forcing applications to import the helpers manually, move them to pykms by turning it into a python module. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'py/pykms/CMakeLists.txt')
-rw-r--r--py/pykms/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/py/pykms/CMakeLists.txt b/py/pykms/CMakeLists.txt
index 3e6e0e1..a671b7a 100644
--- a/py/pykms/CMakeLists.txt
+++ b/py/pykms/CMakeLists.txt
@@ -21,6 +21,10 @@ target_link_libraries(pykms kms++ kms++util ${LIBDRM_LIBRARIES})
# Don't add a 'lib' prefix to the shared library
set_target_properties(pykms PROPERTIES PREFIX "")
+set_target_properties(pykms PROPERTIES LIBRARY_OUTPUT_DIRECTORY "")
-# XXX Where should pykms.so be installed?
-#install(TARGETS pykms DESTINATION lib)
+configure_file(__init__.py __init__.py COPYONLY)
+
+set(PY_DESTDIR lib/python${PYTHON_VERSION}/site-packages/pykms)
+install(FILES __init__.py DESTINATION ${PY_DESTDIR})
+install(TARGETS pykms DESTINATION ${PY_DESTDIR})