summaryrefslogtreecommitdiff
path: root/py/pykms/CMakeLists.txt
diff options
context:
space:
mode:
authorLaurent Pinchart <laurent.pinchart@ideasonboard.com>2016-12-08 01:11:44 +0200
committerLaurent Pinchart <laurent.pinchart@ideasonboard.com>2017-04-16 19:12:43 +0300
commit5610b6440617246972105a93ca6a35c9ed045db4 (patch)
tree0459a58382ce3addd3e25b2c7b158a87c17b635a /py/pykms/CMakeLists.txt
parent9847712d62ab55c5aff4abaf92c9093566b50cd1 (diff)
Remove libdrm_omap dependency
The library is just a wrapper around ioctls. It doesn't provide much value, and its API is marked as experimental and should thus not be expected to be stable. As third party library dependencies are always painful for distributors and packagers, use the ioctls directly for now. Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Diffstat (limited to 'py/pykms/CMakeLists.txt')
-rw-r--r--py/pykms/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/py/pykms/CMakeLists.txt b/py/pykms/CMakeLists.txt
index 505c0c3..56a9c35 100644
--- a/py/pykms/CMakeLists.txt
+++ b/py/pykms/CMakeLists.txt
@@ -1,3 +1,4 @@
+include_directories(${PROJECT_BINARY_DIR}) # for config.h
include_directories(${LIBDRM_INCLUDE_DIRS})
link_directories(${LIBDRM_LIBRARY_DIRS})
@@ -12,7 +13,7 @@ include_directories(${PROJECT_SOURCE_DIR}/ext/pybind11/include)
set(SRCS pykms.cpp pykmsbase.cpp pykmsutil.cpp pyvid.cpp)
-if(LIBDRM_OMAP_FOUND)
+if(HAVE_OMAP_DRM)
set(SRCS ${SRCS} pykmsomap.cpp)
endif()