summaryrefslogtreecommitdiff
path: root/py/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2015-10-23 23:37:06 +0300
committerTomi Valkeinen <tomi.valkeinen@ti.com>2015-10-23 23:37:06 +0300
commita95d7eae23770c6bb55a0126a3cccd7a692ed792 (patch)
tree501d1fa56d983b5fdb44717c9b3a050f287136d3 /py/CMakeLists.txt
parent6171cedfddfc864898c3f32a70b370c39e36faa1 (diff)
pykms: use -builtin
Diffstat (limited to 'py/CMakeLists.txt')
-rw-r--r--py/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/py/CMakeLists.txt b/py/CMakeLists.txt
index 42dae20..4b1f3ea 100644
--- a/py/CMakeLists.txt
+++ b/py/CMakeLists.txt
@@ -12,11 +12,15 @@ include_directories(${PYTHON_INCLUDE_DIRS})
include_directories(../libkms++ ../libkmstest)
#set(CMAKE_SWIG_FLAGS "-I../../libkms")
+set(CMAKE_SWIG_FLAGS "-builtin")
set_source_files_properties(pykms.i PROPERTIES CPLUSPLUS ON)
swig_add_module(pykms python pykms.i)
swig_link_libraries(pykms kms++ kmstest ${LIBDRM_LIBRARIES} ${PYTHON_LIBRARIES})
+# We get some "maybe-uninitialized" warnings from the generated code. I hope they are harmless.
+set_source_files_properties(${swig_generated_file_fullname} PROPERTIES COMPILE_FLAGS "-Wno-maybe-uninitialized")
+
add_custom_target(pyextras SOURCES test.py functest.py db.py)
add_test(NAME pytest COMMAND "${CMAKE_CURRENT_SOURCE_DIR}/functest.py")