summaryrefslogtreecommitdiff
path: root/kms++/CMakeLists.txt
diff options
context:
space:
mode:
authorMatt Hoosier <matt.hoosier@garmin.com>2020-03-03 09:25:25 -0600
committerMatt Hoosier <matt.hoosier@garmin.com>2020-03-03 09:39:11 -0600
commit5d50c15234b78597d78bcddc911ecb4cb9cc123b (patch)
tree2ec2c189465a698a41bd208ce83ed9a1d76b7523 /kms++/CMakeLists.txt
parent7c5e645112a899ad018219365c3898b0e896353f (diff)
Supply pkg-config files
These are customary, and pretty straightforward to offer.
Diffstat (limited to 'kms++/CMakeLists.txt')
-rw-r--r--kms++/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/kms++/CMakeLists.txt b/kms++/CMakeLists.txt
index c02cc83..6e21fa5 100644
--- a/kms++/CMakeLists.txt
+++ b/kms++/CMakeLists.txt
@@ -24,6 +24,8 @@ target_include_directories(kms++ PUBLIC
target_link_libraries(kms++ ${LIBDRM_LIBRARIES} ${LIBDRM_OMAP_LIBRARIES} fmt::fmt-header-only)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/kms++.pc.in ${CMAKE_CURRENT_BINARY_DIR}/kms++.pc @ONLY)
+
# Set a dummy SOVERSION just to avoid having a naked .so file in the filesystem.
# This version number doesn't make any promise about API/ABI stability.
set_target_properties(kms++ PROPERTIES
@@ -34,3 +36,6 @@ install(TARGETS kms++
LIBRARY DESTINATION lib
ARCHIVE DESTINATION lib
PUBLIC_HEADER DESTINATION include/kms++)
+
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/kms++.pc
+ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)