summaryrefslogtreecommitdiff
path: root/kms++/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2019-09-24 12:52:14 +0300
committerTomi Valkeinen <tomi.valkeinen@ti.com>2019-09-25 14:49:06 +0300
commit40bc9d1095228ab1377625be3479491263d696d7 (patch)
tree68e02263767217c5302788a7c974c3786fb9e44b /kms++/CMakeLists.txt
parentf887436cebefd30f2bfadcfb7210703baa8ca93c (diff)
videomode to_string improvements
Add to_string_short() and to_string_long() to videomode (using the fmt library) for easy printing of videomodes. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
Diffstat (limited to 'kms++/CMakeLists.txt')
-rw-r--r--kms++/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/kms++/CMakeLists.txt b/kms++/CMakeLists.txt
index 10352a2..1ca8815 100644
--- a/kms++/CMakeLists.txt
+++ b/kms++/CMakeLists.txt
@@ -22,7 +22,7 @@ target_include_directories(kms++ PUBLIC
$<INSTALL_INTERFACE:include>
PRIVATE src)
-target_link_libraries(kms++ ${LIBDRM_LIBRARIES} ${LIBDRM_OMAP_LIBRARIES})
+target_link_libraries(kms++ ${LIBDRM_LIBRARIES} ${LIBDRM_OMAP_LIBRARIES} fmt::fmt)
set_target_properties(kms++ PROPERTIES
PUBLIC_HEADER "${PUB_HDRS}")