summaryrefslogtreecommitdiff
path: root/kms++/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2016-06-11 20:17:35 +0300
committerTomi Valkeinen <tomi.valkeinen@ti.com>2016-06-11 20:17:35 +0300
commit17d180891f1e237ea5d25835999a8b23a6e7946d (patch)
tree5963fe4d338f6272daf55c76ed355effb47afc71 /kms++/CMakeLists.txt
parent38a71ee72c47f3287c327113ce411f236cac05ef (diff)
rename dirs
Diffstat (limited to 'kms++/CMakeLists.txt')
-rw-r--r--kms++/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/kms++/CMakeLists.txt b/kms++/CMakeLists.txt
new file mode 100644
index 0000000..4409b8b
--- /dev/null
+++ b/kms++/CMakeLists.txt
@@ -0,0 +1,8 @@
+include_directories(${LIBDRM_INCLUDE_DIRS})
+link_directories(${LIBDRM_LIBRARY_DIRS})
+
+file(GLOB SRCS "*.cpp" "*.h")
+add_library(kms++ ${SRCS})
+
+target_link_libraries(kms++ ${LIBDRM_LIBRARIES})
+target_include_directories(kms++ PUBLIC ${CMAKE_CURRENT_SOURCE_DIR})