summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@iki.fi>2015-09-30 22:38:28 +0300
committerTomi Valkeinen <tomi.valkeinen@iki.fi>2015-10-01 19:40:22 +0300
commitba853e936dd33f32291b2958c13530d5796b575c (patch)
tree755bd8e9e22843ee9211ce1785929e62fff9c668 /CMakeLists.txt
parent9820f004f2be68cdf680f16b6ef341ed318c4870 (diff)
add options to turn off py/lua build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 433418e..8a20996 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,8 @@ IF(NOT CMAKE_BUILD_TYPE)
FORCE)
ENDIF(NOT CMAKE_BUILD_TYPE)
+set(LIBKMS_ENABLE_PYTHON ON CACHE BOOL "Enable Python wrappers")
+set(LIBKMS_ENABLE_LUA ON CACHE BOOL "Enable Lua wrappers")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall")
@@ -22,6 +24,11 @@ enable_testing()
add_subdirectory(libkms++)
add_subdirectory(tests)
-add_subdirectory(py)
-add_subdirectory(lua)
+if(LIBKMS_ENABLE_PYTHON)
+ add_subdirectory(py)
+endif()
+
+if(LIBKMS_ENABLE_LUA)
+ add_subdirectory(lua)
+endif()