summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlejandro Hernandez <ajhernandez@ti.com>2017-02-03 10:11:58 -0500
committerTomi Valkeinen <tomi.valkeinen@ti.com>2017-02-06 12:59:32 +0200
commit643d678146f0e292ed211e9fe214c145e697d2d4 (patch)
treecd9c12a54ad64f5b652bb78840dd9e5b8073adf5 /CMakeLists.txt
parent0286945fdda0dee8881c0e00ef8942ac3f7999c9 (diff)
Support python2 based pykms binding
Previously only binding with python3 was supported, this patch allows compilation of pykms with python3 or python2. When compiling with python2 some of the python scripts located in the py/test will not work since they import python3 only modules Signed-off-by: Alejandro Hernandez <ajhernandez@ti.com> Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 324b7df..57088bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,8 @@ option(BUILD_SHARED_LIBS "Build shared libs" FALSE)
option(TREAT_WARNINGS_AS_ERRORS "Treat warnings as errors" FALSE)
set(KMSXX_ENABLE_PYTHON ON CACHE BOOL "Enable Python wrappers")
+set(KMSXX_PYTHON_VERSION "python3;python2" CACHE STRING "Python pkgconfig package")
+
set(KMSXX_ENABLE_KMSCUBE OFF CACHE BOOL "Enable kmscube")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11 -Wall")