summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2016-06-11 20:33:18 +0300
committerTomi Valkeinen <tomi.valkeinen@ti.com>2016-06-11 20:46:03 +0300
commitc5f166179b578b728aa2e47460b604d119a940b3 (patch)
treec46ba86bab1896b6e9dec66d93db81b7a909c556 /CMakeLists.txt
parent17d180891f1e237ea5d25835999a8b23a6e7946d (diff)
cmake: add option to build shared libs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d60ed15..40cc19f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,8 @@ ENDIF()
string(TOUPPER "${CMAKE_BUILD_TYPE}" U_CMAKE_BUILD_TYPE)
+option(BUILD_SHARED_LIBS "Build shared libs" FALSE)
+
set(LIBKMS_ENABLE_PYTHON ON CACHE BOOL "Enable Python wrappers")
set(LIBKMS_ENABLE_KMSCUBE OFF CACHE BOOL "Enable kmscube")