summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomi Valkeinen <tomi.valkeinen@ti.com>2018-08-23 13:11:41 +0300
committerTomi Valkeinen <tomi.valkeinen@ti.com>2018-08-23 13:21:28 +0300
commit40d96062a37ca924a66a926a234b35644928d4a7 (patch)
treec0f5c95473af017a66b9ef7ad66a6c4f7a964aa9 /CMakeLists.txt
parent4dae98543f848095542a51b8c23322edf07c192e (diff)
Revert "testpat: remove threaded drawing"
This reverts commit 33246d9b5fb0347aabd62caac1da03440f9e1634. Add threaded drawing back, but have it behind a CMAKE variable so that it can easily be turned off. Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57088bc..f2f24fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,6 +25,8 @@ set(KMSXX_PYTHON_VERSION "python3;python2" CACHE STRING "Python pkgconfig packag
set(KMSXX_ENABLE_KMSCUBE OFF CACHE BOOL "Enable kmscube")
+set(KMSXX_ENABLE_THREADING ON CACHE BOOL "Enable threading for parallelized drawing")
+
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11 -Wall")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra -Wno-unused-parameter")