summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9354c90..b9573145 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,11 @@ AC_ARG_ENABLE(udev, AS_HELP_STRING([--enable-udev],
[Enable support for using udev instead of mknod (default: disabled)]),
[UDEV=$enableval], [UDEV=no])
+AC_ARG_ENABLE(libkms,
+ AS_HELP_STRING([--enable-libkms],
+ [Enable KMS mm abstraction library (default: disabled)]),
+ [LIBKMS=$enableval], [LIBKMS=no])
+
AC_ARG_ENABLE(intel,
AS_HELP_STRING([--disable-intel],
[Enable support for intel's KMS API (default: auto)]),
@@ -139,6 +144,8 @@ if test "x$UDEV" = xyes; then
AC_DEFINE(UDEV, 1, [Have UDEV support])
fi
+AM_CONDITIONAL(HAVE_LIBKMS, [test "x$LIBKMS" = xyes])
+
AM_CONDITIONAL(HAVE_VMWGFX, [test "x$VMWGFX" = xyes])
AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes])
@@ -206,6 +213,8 @@ AC_SUBST(kernel_source)
AC_SUBST(WARN_CFLAGS)
AC_OUTPUT([
Makefile
+ libkms/Makefile
+ libkms/libkms.pc
intel/Makefile
intel/libdrm_intel.pc
radeon/Makefile
@@ -222,6 +231,7 @@ AC_OUTPUT([
echo ""
echo "$PACKAGE_STRING will be compiled with:"
echo ""
+echo " libkms $LIBKMS"
echo " Intel API $INTEL"
echo " vmwgfx API $VMWGFX"
echo " Radeon API $RADEON"